注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

我的博客

小猪哥

 
 
 

日志

 
 

ros安装教程  

2010-06-17 22:35:40|  分类: 网吧技术 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

2009年06月21日 星期日 20:05

ROS软路由基本设置非常简单,如果只做路由转发,以下几步数分钟即可高定:
硬件准备:
1、首先下载软路由的ghost硬盘版,如果没有,从www.nbwq.com/download/ros297.rar下载
2、释放后,ghost至一个小硬盘(20G以下),注意,是整盘GHOST而不是分区。
3、将该硬盘挂在要做路由电脑上,注意必须接在第一个IDE并且是主硬盘接口。插上一张网卡,这是接内网的LAN。开机。
软件设置:
1、开机,出现登陆提示。用户:admin 密码:空
2、输入setup再按两次A  
3、在ether1后面输入你的内网IP,如:192.168.0.254/24 (这里/24是24位掩码与255.255.255.0一样)
4、输入完ip后,按两次x退出,现在可以可以ping通192.168.0.254了,也可用winbox在图形界面下访问路由了。
5、关机,插上另一张网卡,这个是接外网的,即WAN,现在可以去掉软路由电脑的显示器和键盘了。
6、开机,运行winbox以admin身份登陆
7、添加外网网卡。在ip---address里按+,address输入你的外网ip和掩码位,比如218.56.37.11/29。network和BROADCAST不填,INTERFACE里选择ethr2
8、增加外网网关。ip-routes按+,Destination用默认的0.0.0.0/0 ,Gateway输入外网网关,比如218.56.37.10
9、实现NAT转发:IP-FIREWALL在NAT里点+,在ACTION里选masquerade
10、现在该路由已经做好雏形,可以正常上网了。其他的诸如防火墙、双线策略等,可以参考其他资料。

这篇文章是我自己按经验来编写的,安装过程太简单了,就不说了,希望能帮到大家
安装完成后什么都没有设置的情况下.登录
用户: admin  
密码: 为空
1、查看已安装的网卡
>/int
>pri
2、确认已安装两块网卡后,如果看到网卡前面的英文为X,则要激活网卡,2.9系列版本是自动激活网卡的.
>enable 0
>enable 1
3、激活之后网卡前面的英文为R,然后改网卡名字,
>set 0 name=lan
>set 1 name=wan
>/
这里“/”为退出的意思
4、设置内网卡IP和子网掩码
>set
>a
>a
>lan
回车后输入你服务器内网卡的IP地址,我的内网卡的IP地址是192.168.1.1 ,下面IP后面的“/24”是代表子网掩码255.255.255.0 ,
192.168.1.1/24
回车后按G设置网关
192.168.1.1
5、设置外网卡IP和子网掩码
>set
>a
>a
>wan
回车后输入你服务器外网卡的IP地址,下面IP后面的“/29”是代表子网掩码255.255.255.248,
如果你的子网掩码不是255.255.255.248,请自己计算,不要跟着我填29
210.137.174.1/29
回车后按G设网关
219.137.174.193
然后按X退出。
6、查看IP设置情况
>ip add
>pri
假如网卡1设错,删除设错的网卡,
>remove 1
重启一次,完成后在其它机用winbox登入
7、设置DNS
IP →dns→settings
然后输入
202.96.128.68
202.96.134.133
8、最后一步,设置共享上网
2.9系列的版本选择
IP→Firewall-nat →选择“+”号→Action-masquerade
2.8系列的版本选择
IP→Firewall→选择“+”号→src-nat→add action-masquerade
这样你的ROS就可以共享上网了。其实也很简单的。此设置基本上适合2.8和2.9的各版本
(注释:这里掩码是用8进制,简单说24就等于255.255.255.0 这样简单解释吧
255.255.255.255 = 11111111.11111111.11111111.11111111 这里有32个1,就是32了
255.255.255.0   = 11111111.11111111.11111111.00000000 这就是24了 )
24位=255.255.255.0
25位=255.255.255.128
26位=255.255.255.192
27位=255.255.255.224
28位=255.255.255.240
29位=255.255.255.248
30位=255.255.255.252
31位=255.255.255.254
32位=255.255.255.255


ROS安装录象0


一.新建虚拟机
1.选择自定义
2.最新版本就可以了
3.选择linux 下的other linux
4.名称随便
5.处理器选1个
6.使用桥接网络
7.SCSI适配器选buslogic
8.虚拟磁盘选IDE的
9.硬盘设置为IDE1。光驱设置为IDE0
10.然后点这里找到你下载的ROS的ISO景象文件。
11.虚拟机默认是一块网卡的 然后再添加网卡1快
12.启动
二安装ROS
1.全部选择即可。全选输入A,同意选择输入I,回车,询问你:注意啦,所有数据(功能),都要被安装(选择了),是否继续,输入Y即可。
它又询问,是否保存旧配置,输入N回车,接下来开始创建分区,格式化硬盘,安装服务。提示软件安装完成,输入回车重起。
之后ROS就会独立启动了。。启动后又问了,是否检测硬盘。通常不必检测了,因为耽误时间。默认他自动选N。。我们也可以直接输入N的。。
OK。ROS启动了。输入账号ADMIN。默认为空密码。
可以了。登陆进来了。因为是破解版。所以不会提示未注册。
输入命令/int pri
查看网卡是否两快
2.设置ROS的IP地址
输入命令/ip address
我的2块网卡都认到了,如果你的没有认到,请重新插下网卡,或者更换其他网卡
输入命令add address=192.168.0.1/24 interface=ether1
好了。ROS的IP地址设定好了,我设置的是192.168.0.1为网关地址。大家根据自己的实际情况设置就可以了。/24是为啥,
相信不必多说了。这个/就是子网掩码的2进制1的个数,一个十进制255等于8个二进制的1,我设置子网掩码为
255.255.255.0。所以就是3个十进制的8个1。也就是24啦。OK。继续。。在IE里输入http://192.168.0.1来访问ROS。
呵呵,顺利,打开了ROS的WEB界面。那么下载WINBOX吧。
账号为admin密码为空。
3.进入WEB界面配置等以后在讲


ros 2.9 网吧配制教程
2007-10-16 12:21


网吧专用ros软路由教程(非常详细)

一:安装  

1、光盘版的(转自雨纷飞大哥作品)
将iso文件刻录成可引导光盘。机器的硬盘设置为IDE0,即第一个IDE通道的主盘。
bios设置光盘引导系统,放入光盘启动机器得到如下


ros安装教程 - 小猪哥 - 我的博客
选择 2:Install RouteOS 2.8.18后稍等,得到如下画面:
用方向键和空格选择你需要的模组功能后,按"A"全选,摁“i“键确定安装。会再次询问你继续?yes or no?,摁“Y“.
然后又问:do you want to keep lod configuraton?你需要保留旧的结构么?摁“N
然后开始自动的格式化磁盘、安装核心、安装模组。最后提示:
Press ENTER to Reboot,按回车重新启动机器。
ros安装教程 - 小猪哥 - 我的博客
重新启动后出现图1的那个引导画面(如果没有出现而直接进了登陆界面说明用硬盘引导了):
ros安装教程 - 小猪哥 - 我的博客
选择3: Crack RouteOS Floppy Disk,开始破解。
破解过程都是中文的。如果你的硬盘在IDE0:0的话破解是不会有问题的。否则可能出现系统文件被破坏、启动时0123456...循环出现等问题。
问你是否重启呢。把光盘拿出来后按下Y确定重启动
ros安装教程 - 小猪哥 - 我的博客
重新启动后开始登陆。初始用户名admin,初始密码为空。
咦?怎么还有提示注册的信息和Soft ID?
原来是还需要一个命令激活注册补丁才可以哦:
输入命令:/system license import file-name=key
或者缩写为/sy lic i f key
然后提示你是否重新启动。按Y重新启动
重新启动并用admin:““登陆后发现,提示注册的信息已经完全消失了,现在是正式版了
ros安装教程 - 小猪哥 - 我的博客
现在服务器启动起来了,但是还没有任何配置,若想用winbox对其进行控制,则必须激活和配置网卡的ip 掩码等。这里我装了三块网卡,一块接电信,一块接网通,一块路由后接内网交换机。
首先看看三块网卡是否都被识别出来了,命令是:
/interface
print
可以缩写为
/int
pri
以后用缩写不再另外注名。
结果应该如下图:
ros安装教程 - 小猪哥 - 我的博客
然后我们来激活他们,命令是:
ENABLE 0  
ENABLE 1
ENABLE 2
0是第一块网卡。
激活后没有提示。用print命令查看后发现网卡前面的X变成R,就代表激活成功了。
如下图
ros安装教程 - 小猪哥 - 我的博客
但是ether1 ether2之类的名字实在是抽象不便于以后的配置,所以我们把网卡给改个名字:
命令:
SET 0 NAME=newname
我这里用
set 0 name=dianxin
set 1 name=wangtong
set 2 name=neiwang
如下图:改名成功。
ros安装教程 - 小猪哥 - 我的博客
然后给他们相应的IP。
先返回顶层目录,用/键就可以了。
然后输入:
IP
ADDRESS  
add address 192.168.0.10/24 interface dianxin
add address 192.168.0.11/24 interface wangtong
add address 192.168.0.12/24 interface neiwang
这样就设置好了dianxin、wangtong、内网这三块网卡的IP和子网掩码。24代表255.255.255.0
我只是做实验写教程,具体IP地址还要根据你的实际情况来变动。
添加完毕后可以用print命令来查看结果。如果发现某条有错误,用“remove 错误的编号“既可以删除
ros安装教程 - 小猪哥 - 我的博客
到这里IP的配置就大功告成了,我们终于可以跟文字界面说拜拜了~
2、GHOST版的(原创)
将下载好的G文件放在一块带有ghost的虚拟dos(我的是的MAX—dos)系统上,进ghost选择恢复镜像到全盘(千万别错了哦,是全盘镜像)。完毕重启后无需破解,余下的操作同上,我就不重复了。
二:winbox下调试
根据你所设的局域网IP。输入
http://192.168.1.1
(我的是192.168.1.1) 下载winbox
得到如下图:
ros安装教程 - 小猪哥 - 我的博客
输入管理员用户admin,默认密码为空,如图:
ros安装教程 - 小猪哥 - 我的博客
第一项:interfaces。这里可以更改你的网卡名称,查看个内外网总体
ros安装教程 - 小猪哥 - 我的博客
查看外网流量如图:(选择网卡名称第四项traffic)
ros安装教程 - 小猪哥 - 我的博客
第二项,IP
由于你已经填写好了内外网的IP,所以IP Addresses里无须再管了。注意事项,外网掩码请仔细询问你当地的电信或者网通部门
2、ip routes,这里是更改你所走的网关用的,如图
ros安装教程 - 小猪哥 - 我的博客
3、IP pool(不管他)
4、IP arp(这里是网卡mac地址与ip地址绑定,我是绑定了),具体操作,双击前面带D(代表未arp绑定)的IP地址,点tools选择copy,点OK,哈哈,前面的D就没啦,恭喜你绑定成功。
ros安装教程 - 小猪哥 - 我的博客
5、IP vrrp(不管他)
6、IP firewall(重点哦)
到这里了,是不是还拼不通外网啊,哈哈,没有IP伪装啊,当然上不了啊。IP—firewall—source,点加号加一条规则,第一项里面填你的设置的内网网段,不是网关哦,后面跟24,不是32哦。切记!如图
ros安装教程 - 小猪哥 - 我的博客
能上网了吧,这时候你的软路由非常脆弱,所以,我们来给他增“墙”,本文核心,防火墙配置。
input 设置图:
ros安装教程 - 小猪哥 - 我的博客
一些重要的端口改变图:为什么要改变端口,用途很明显,默认的大家都知道,而你所改的呢?只有你自己知道,哈哈,这就是效果!
ros安装教程 - 小猪哥 - 我的博客
看到没?
比如telnet啊,winbox啊,upnp,http(这里是指访问你的路由的http端口哦)。
forward 设置,这里控制着你网吧的安全核心,先看图:
ros安装教程 - 小猪哥 - 我的博客
其本都是drop drop drop。(阻止的意思啦)
tcp/udp协议的134—139端口,445端口(把三波引进来的就是这个端口,罪大恶极,封封封!)
500端口(这个端口是别人经常攻击你软路由的端口,也封)还有迅雷5啊,P2P啊,QQ幻想啊(你的是100M光纤就别封了,无所谓)
output 设置,此项比较简单,但很重要,syn大家都明白吧。如图:
ros安装教程 - 小猪哥 - 我的博客
virus设置:(也很重要哦)如果你input forward 两项防火没有起到什么作用,可以在里面做个跳转,使之两项转向virus设置。
virus设置图:
ros安装教程 - 小猪哥 - 我的博客
jump(跳转图):
ros安装教程 - 小猪哥 - 我的博客
哈哈,防火墙设置基本完成,不要看似简单,记住写规则的顺序:先允许,后拒绝,别说我没讲哦,否则防火墙会被你配的一团糟,你还以为你的路由很安全呢?哈哈。
端口映射:
这项比较简单,IP—firewall—Destination。先看图:
ros安装教程 - 小猪哥 - 我的博客
ros安装教程 - 小猪哥 - 我的博客
负载平衡:IP—firewall—connections 点Tracking 看我图设置:
ros安装教程 - 小猪哥 - 我的博客
吃午饭啦,下午继续!还有一些东西,经常遇到的问题啊什么的。呵呵。
刚才有人问我配置怎么样,建议网卡用60元左右的吧,8139嘛最好不要用,路由的流量不小哦。慎用慎用。别的硬件倒无所谓,我想现在硬件也不会差到哪里吧,CPU,内存都是超便宜哦。
至于网卡顺序嘛:以三块网卡为例,以我的为例,从主板显卡这边数,依次为3、2、1。
路由水晶头做法:路由与电信的转发包同一设备,所以,你想想是用哪种接法呢?在这里卖个关子,不说。不能什么都喂给你吃哦,有得时候自己动手,学的更多更深!  
我想知的是。软件稳不稳定。。。。。机子配制要不要很高的。100多台的。
还有。能不能控制内网的每个IP 的下载上传的流量。。。。限制以后。会不会导倒内网打开网页慢的。
我前几天就买了侠诺的路由器。它的只能限制内网的总速度的。不能对每个IP的限制。还有这样整体限制上传下载。
会影响到内网打开网页慢。
楼主我想知道这些的。不知大家有没有测试过的。这些问题得到解决没?
机器配置要求不高,由于没有128的内存,我用的是256的,由于没有815的板子,我用的845的,由于没有cy1.7的CPU,我用的是2.0的,关键在网卡配置。呵 呵,ROS可以单个IP限速,不过我从来不限,防火墙配置好了,限速干什么呢?限速后玩游戏,网页都很正常。但有人提及过刷浩方问题,由于我不限速,所以,至今没发现。大家要限速的请看下面:Queues项的Simple queue:
ros安装教程 - 小猪哥 - 我的博客
我的前面都是X,就是没有启用的意思啦,关键时候用一下,哈哈。
ros下怎样用命令关机?
system—shutdown

1、安装ROS
除了自己学习和测试用ROS外,最好还是单独用一台机器,相信这也不用多说,安装的时候要注意的是硬盘一定要接在IDE0上面,并且作为主盘MASTER,光驱随便,很多安装之后不能正常启动的都是这个问题、用安装光盘启动后,如图


ros安装教程 - 小猪哥 - 我的博客

选择 i 进入安装界面选择需要安装的package


ros安装教程 - 小猪哥 - 我的博客

选择完后,再按i安装,y确定,再按n不保存旧配置。最后回车重新启动,这时进入ROS是未注册的版本



ros安装教程 - 小猪哥 - 我的博客
用光驱启动,在启动菜单按c破解
ros安装教程 - 小猪哥 - 我的博客

破解之后进入已经没有了未注册提示。。。


ros安装教程 - 小猪哥 - 我的博客

2、服务端配置
/interface pri     能显示出你现在可用的网卡。如图


ros安装教程 - 小猪哥 - 我的博客

/ip address
add address=192.168.1.1/24 interface=ether1   
设置ether1为内网IP,其中192.168.1.1/24添自己的内网IP ,设置成功没有提示,可以用pri查看


ros安装教程 - 小猪哥 - 我的博客

3、winbox配置(所有配置都在这里进行)
在局域网其他机器IE浏览器192.168.1.1 进入WEBBOX,左边可以下载WINBOX,当然如果你已经有WINBOX可以省略这步。打开WINBOX输入IP和用户名连接


ros安装教程 - 小猪哥 - 我的博客

进入配置界面
(1)点左侧INTERFACE,双击ether1将name改为lan,同样将另两个改为cnc和tel。


ros安装教程 - 小猪哥 - 我的博客

(2)左侧IP->ADDRESS ,+号,分别设置CNC和TEL的IP地址,添网通和电信给的IP/子网掩码(不要和我的一样...),红叉部分是自动添加的


ros安装教程 - 小猪哥 - 我的博客

3)IP->ROUTE,+号添加默认的网关,默认网通就添网通网关,默认电信就添电信的网关,这里默认电信.
如图11,正常下黑圈处为AS,黄圈出为TEL.comment设注释为tel


ros安装教程 - 小猪哥 - 我的博客

(4)IP->FIREWALL,NAT选项卡,+号添加chain:srcnat,src.addr:192.168.1.0/24,ACTION选项卡里为masquerade.OK,现在可以通过电信上网了


ros安装教程 - 小猪哥 - 我的博客

(5)
  
   上传路由表文件cnc.rscFTP://admin:@192.168.1.1


ros安装教程 - 小猪哥 - 我的博客

在WINBOX中,NEW TERMINAL,输入import cnc完成


ros安装教程 - 小猪哥 - 我的博客

现在已经可以电信网通自动切换了.
(6)只是切换也不太安全,一定要配制一下防火墙么,同5一样,上传防火墙的RSC文件到192.168.1.1,在NEW TERMINAL里执行import firewall,整体和第5步相近.
(7)配置的差不多了,该改管理员账号了,左侧USERS,双击ADMIN改个名字和右下脚的password,如果不需要远程修改ROS的话,可以设定访问IP,192.168.1.0/24之类的


ros安装教程 - 小猪哥 - 我的博客


  评论这张
 
阅读(2435)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017